GBase 8a执行节点替换replace报错current gcware version and package gcware version are not same

GBase 8a在做节点替换replace时,会检测安装版本和当前集群版本是否一致,如果不同会报如下类似错误:current gcware version (107816) and package gcware version (92755) are not same.解决方法就是采用和当前集群相同的版本进行节点替换。

参考

GBase 8a V95版本节点替换操作手顺

GBase 8a 强制节点离线和节点替换replace

报错样例

原因

看如上错误信息,当前运行的集群版本,svn是107816,而安装包的版本 svn是92755,不一样。

查看安装包的BUILDINFO,对应8.6.2Build20R9, 而运行中的集群版本是 8.6.2Build20R17。

GBase 8a集群如何查看版本号

解决方案

选择相同的安装包进行节点替换。

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注